Cisco Lab Setup

When it comes to learning and getting started with Cisco there are some tools that will help out a lot like Packet Tracer, GNS3 and other emulators. These are great tools for that “simulation” of hands on learning, but you can’t always stay in that area. I find it best to get hands on with “real” Cisco Gear and so with this post I’ll go through my current setup of what I have and ask that question when it is a good time to get a lab? Just because you may want to get a lab that does not guarantee you’ll actually learn and or pass.  

I’ll cut right to it and break it down; I have the following items:

  • 1 x Tripp Lite SRW9U 9U Wall Mount Rack
  • 2 x Cisco 2811 Routers with IOS Security
  • 1x  Cisco 1841 Router with IOS SP Services
  • 1 x Cisco Catalyst 2960 Switch 48 ports (LAN Base)
  • 1 x Cisco ASA 5505 – Base
  • 1 x Cisco AS2509-RJ – Used as an access server

All of these devices are connected via a console cable to the Cisco 2509 and then a single console cable from the 2509 to my machine. This runs VMware Workstation 9 which I just upgraded by the way 🙂 and these virtual machines connect directly to one of the three NICs I have on my machine. These then connect to a Cisco Switch which has four different VLANs (counting the default native VLAN) each assigned to a different range of ports which is seen in the code below:

Switch#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/37, Fa0/38, Fa0/39, Fa0/40
                                                Fa0/41, Fa0/42, Fa0/43, Fa0/44
                                                Fa0/45, Fa0/46, Fa0/47, Fa0/48
                                                Gi0/1, Gi0/2
20   ONE-12                           active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                                Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                                Fa0/9, Fa0/10, Fa0/11, Fa0/12
30   12-24                            active    Fa0/13, Fa0/14, Fa0/15, Fa0/16
                                                Fa0/17, Fa0/18, Fa0/19, Fa0/20
                                                Fa0/21, Fa0/22, Fa0/23, Fa0/24
40   25-36                            active    Fa0/25, Fa0/26, Fa0/27, Fa0/28
                                                Fa0/29, Fa0/30, Fa0/31, Fa0/32
                                                Fa0/33, Fa0/34, Fa0/35, Fa0/36
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
20   enet  100020     1500  -      -      -        -    -        0      0
30   enet  100030     1500  -      -      -        -    -        0      0
40   enet  100040     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0
1003 tr    101003     1500  -      -      -        -    -        0      0
1004 fdnet 101004     1500  -      -      -        ieee -        0      0
1005 trnet 101005     1500  -      -      -        ibm  -        0      0

Remote SPAN VLANs
------------------------------------------------------------------------------

Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------

Switch#

The three NICs on my machine that I use for VMs are not useable to my machine locally. As I have disabled IPv4 and only left the VMware Bridge Protocol selected under the adapter properties, from there I have also edited the VMware Virtual Network Editor as follows and pictured below:

  • VMnet1 – Is bridged to my motherboard NIC and directly connected to a VM
  • VMnet2 – Is bridged to an Intel Gigabit PCI express card and directly connected to VM
  • VMnet3 – Is bridged to an Intel Gigabit PCI express card and directly connected to VM

Here is a picture of my current setup (The ASA is not in this picture):

My Current Cisco Lab

Second Picture of the Rack with the door closed:

My Current Lab with the door closed

Here is a screenshot of the one the NICs Properties:

Here is a screenshot of the VMware Virtual Network Editor and how each NIC is bridged and directly connected to a VM:

When I want a machine to use a NIC I just select one of the VMnet profiles as captured below:

So I talked about my current lab setup which will always continue to grow and be upgraded in time just like a “real” environment but there is another question when do you need lab? I would only setup a lab on at least one of these three conditions:

  • You have money to burn. This lab although small cost around $1,000 bucks.
  • You see yourself going to higher certification levels CCNA Security, Wireless, Voice, CCNP, CCIE and not just the CCNA.
  • You absolutely love this stuff!

For me it was option three that sold me, not only do I see myself working to higher certs but having that physical gear in hand is always the best type of learning (I think). When you go through your studies instead of just believing the answer, prove it by setting up the example physically instead of a point and click setup through simulation/emulation. I hope this information is helpful and if you have any questions about my lab and or other questions comment below.

Advertisements

2 thoughts on “Cisco Lab Setup

  1. adam September 17, 2012 / 2:46 pm

    Where did you get your lab?

    • Ryan September 17, 2012 / 6:52 pm

      Hey Adam,

      The equipment for this lab I put together from Ebay.

      Ryan

Comments are closed.