Configuring EIGRP - Named Mode

Share on:

From its older brother IGRP which was developed in 1980s to overcome the limitations of RIP, EIGRP was an "Enhanced" IGRP protocol. The main purpose of EIGRP was to  overcome the limitations of classful networks and make EIGRP a classless routing protocol. During designing of this protocol a different convergence algorithm was used making EIGRP that "hybrid" between distance-vector and link-state routing protocols. In this post we'll go over a basic design and setup for EIGRP, however instead of using the "classic way" let's look at configuring EIGRP using named mode which is available in Cisco IOS starting in version 15.2

This topology is pretty simple, I have three routers and each them is connected to the other two routers.

All routers have been setup with their local addresses and can ping any network that is locally attached to them. There are two ways to configure EIGRP we could configure it the "classic way" or use named mode. Nothing has changed with EIGRP itself so you could have one router use classic and another router use named mode and the protocol would exchange routing information between the two. The change is to simplify the configuration into one spot, which is under the router EIGRP process instead of having some EIGRP configuration under each interface. Let's get started.

Create a named EIGRP process on all routers:

1R1(config)#router eigrp CISCOSKILLS
2R2(config)#router eigrp CISCOSKILLS
3R3(config)#router eigrp CISCOSKILLS

Note: The named EIGRP process does not have match on all routers to exchange routes.

Create an autonomous system for all routers:

1R1(config-router)# address-family ipv4 unicast autonomous-system 1
2R2(config-router)# address-family ipv4 unicast autonomous-system 1
3R3(config-router)# address-family ipv4 unicast autonomous-system 1

Note: This has to match on all routers if you want EIGRP to exchange routes with.

We'll want to configure a passive interface on the LAN side of each router so we don't send EIGRP neighbor adjacencies into LAN side of the network.

 1R1(config-router-af)#af-interface GigabitEthernet0/1
 2R1(config-router-af-interface)#passive-interface
 3R1(config-router-af-interface)#exit-af-interface
 4 
 5R2(config-router-af)#af-interface GigabitEthernet0/3
 6R2(config-router-af-interface)#passive-interface
 7R2(config-router-af-interface)#exit-af-interface
 8 
 9R3(config-router-af)#af-interface GigabitEthernet0/3
10R3(config-router-af-interface)#passive-interface
11R3(config-router-af-interface)#exit-af-interface

Next we need to configure what networks we want EIGRP to advertise as well as the router-id this configuration will depend on each router:

 1R1(config-router-af)#network 10.0.1.2 0.0.0.0
 2R1(config-router-af)#network 10.0.1.10 0.0.0.0
 3R1(config-router-af)#network 10.1.1.1 0.0.0.0
 4R1(config-router-af)#eigrp router-id 10.1.1.1
 5R1(config-router-af)#exit-address-family
 6 
 7R2(config-router-af)#network 10.0.1.6 0.0.0.0
 8R2(config-router-af)#network 10.0.1.9 0.0.0.0
 9R2(config-router-af)#network 10.2.1.1 0.0.0.0
10R2(config-router-af)#eigrp router-id 10.2.1.1
11R2(config-router-af)#exit-address-family
12 
13R3(config-router-af)#network 10.0.1.1 0.0.0.0
14R3(config-router-af)#network 10.0.1.5 0.0.0.0
15R3(config-router-af)#network 10.3.1.1 0.0.0.0
16R3(config-router-af)#eigrp router-id 10.3.1.1
17R3(config-router-af)#exit-address-family

If everything went to plan we should have some log messages notifying us that adjacencies have been made on each router and we should be able ping/connect to each PC in this network. Using the command show ip route confirms this on all three routers:

 1R1#show ip route
 2Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
 3       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 4       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 5       E1 - OSPF external type 1, E2 - OSPF external type 2
 6       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 7       ia - IS-IS inter area, * - candidate default, U - per-user static route
 8       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
 9       a - application route
10       + - replicated route, % - next hop override, p - overrides from PfR
11 
12Gateway of last resort is not set
13 
14      10.0.0.0/8 is variably subnetted, 9 subnets, 3 masks
15C        10.0.1.0/30 is directly connected, GigabitEthernet0/2
16L        10.0.1.2/32 is directly connected, GigabitEthernet0/2
17D        10.0.1.4/30 [90/15360] via 10.0.1.9, 01:08:45, GigabitEthernet0/3
18                     [90/15360] via 10.0.1.1, 01:08:45, GigabitEthernet0/2
19C        10.0.1.8/30 is directly connected, GigabitEthernet0/3
20L        10.0.1.10/32 is directly connected, GigabitEthernet0/3
21C        10.1.1.0/24 is directly connected, GigabitEthernet0/1
22L        10.1.1.1/32 is directly connected, GigabitEthernet0/1
23D        10.2.1.0/24 [90/15360] via 10.0.1.9, 01:08:45, GigabitEthernet0/3
24D        10.3.1.0/24 [90/15360] via 10.0.1.1, 01:08:45, GigabitEthernet0/2
25R1#
26 
27R2#show ip route
28Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
29       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
30       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
31       E1 - OSPF external type 1, E2 - OSPF external type 2
32       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
33       ia - IS-IS inter area, * - candidate default, U - per-user static route
34       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
35       a - application route
36       + - replicated route, % - next hop override, p - overrides from PfR
37 
38Gateway of last resort is not set
39 
40      10.0.0.0/8 is variably subnetted, 9 subnets, 3 masks
41D        10.0.1.0/30 [90/15360] via 10.0.1.10, 01:08:35, GigabitEthernet0/2
42                     [90/15360] via 10.0.1.5, 01:08:35, GigabitEthernet0/1
43C        10.0.1.4/30 is directly connected, GigabitEthernet0/1
44L        10.0.1.6/32 is directly connected, GigabitEthernet0/1
45C        10.0.1.8/30 is directly connected, GigabitEthernet0/2
46L        10.0.1.9/32 is directly connected, GigabitEthernet0/2
47D        10.1.1.0/24 [90/15360] via 10.0.1.10, 01:08:35, GigabitEthernet0/2
48C        10.2.1.0/24 is directly connected, GigabitEthernet0/3
49L        10.2.1.1/32 is directly connected, GigabitEthernet0/3
50D        10.3.1.0/24 [90/15360] via 10.0.1.5, 01:08:35, GigabitEthernet0/1
51R2#
52 
53R3#show ip route
54Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
55       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
56       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
57       E1 - OSPF external type 1, E2 - OSPF external type 2
58       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
59       ia - IS-IS inter area, * - candidate default, U - per-user static route
60       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
61       a - application route
62       + - replicated route, % - next hop override, p - overrides from PfR
63 
64Gateway of last resort is not set
65 
66      10.0.0.0/8 is variably subnetted, 9 subnets, 3 masks
67C        10.0.1.0/30 is directly connected, GigabitEthernet0/1
68L        10.0.1.1/32 is directly connected, GigabitEthernet0/1
69C        10.0.1.4/30 is directly connected, GigabitEthernet0/2
70L        10.0.1.5/32 is directly connected, GigabitEthernet0/2
71D        10.0.1.8/30 [90/15360] via 10.0.1.6, 01:08:14, GigabitEthernet0/2
72                     [90/15360] via 10.0.1.2, 01:08:14, GigabitEthernet0/1
73D        10.1.1.0/24 [90/15360] via 10.0.1.2, 01:08:14, GigabitEthernet0/1
74D        10.2.1.0/24 [90/15360] via 10.0.1.6, 01:08:14, GigabitEthernet0/2
75C        10.3.1.0/24 is directly connected, GigabitEthernet0/3
76L        10.3.1.1/32 is directly connected, GigabitEthernet0/3
77R3#

We can see by default in the routing table that EIGRP has already calculated the best route to each LAN and has only put in one route to reach them. If we show the EIGRP topology we notice that EIGRP has these routes ready in case if the primary route to reach these LANs fail.

 1R1#show ip eigrp topology all-links
 2EIGRP-IPv4 VR(CISCOSKILLS) Topology Table for AS(1)/ID(10.1.1.1)
 3Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
 4      r - reply Status, s - sia Status 
 5
 6P 10.0.1.0/30, 1 successors, FD is 1310720, serno 1
 7       via Connected, GigabitEthernet0/2
 8P 10.0.1.4/30, 2 successors, FD is 1966080, serno 6
 9       via 10.0.1.1 (1966080/1310720), GigabitEthernet0/2
10       via 10.0.1.9 (1966080/1310720), GigabitEthernet0/3
11P 10.0.1.8/30, 1 successors, FD is 1310720, serno 5
12       via Connected, GigabitEthernet0/3
13P 10.2.1.0/24, 1 successors, FD is 1966080, serno 7
14       via 10.0.1.9 (1966080/1310720), GigabitEthernet0/3
15       via 10.0.1.1 (2621440/1966080), GigabitEthernet0/2
16P 10.1.1.0/24, 1 successors, FD is 1310720, serno 8
17       via Connected, GigabitEthernet0/1
18P 10.3.1.0/24, 1 successors, FD is 1966080, serno 3
19       via 10.0.1.1 (1966080/1310720), GigabitEthernet0/2
20       via 10.0.1.9 (2621440/1966080), GigabitEthernet0/3
21
22R2#show ip eigrp topology all-links
23EIGRP-IPv4 VR(CISCOSKILLS) Topology Table for AS(1)/ID(10.2.1.1)
24Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
25      r - reply Status, s - sia Status 
26
27P 10.0.1.0/30, 2 successors, FD is 1966080, serno 16
28       via 10.0.1.5 (1966080/1310720), GigabitEthernet0/1
29       via 10.0.1.10 (1966080/1310720), GigabitEthernet0/2
30P 10.0.1.4/30, 1 successors, FD is 1310720, serno 1
31       via Connected, GigabitEthernet0/1
32P 10.0.1.8/30, 1 successors, FD is 1310720, serno 2
33       via Connected, GigabitEthernet0/2
34P 10.2.1.0/24, 1 successors, FD is 1310720, serno 3
35       via Connected, GigabitEthernet0/3
36P 10.1.1.0/24, 1 successors, FD is 1966080, serno 17
37       via 10.0.1.10 (1966080/1310720), GigabitEthernet0/2
38       via 10.0.1.5 (2621440/1966080), GigabitEthernet0/1
39P 10.3.1.0/24, 1 successors, FD is 1966080, serno 7
40       via 10.0.1.5 (1966080/1310720), GigabitEthernet0/1
41       via 10.0.1.10 (2621440/1966080), GigabitEthernet0/2
42
43R3#show ip eigrp topology all-links
44EIGRP-IPv4 VR(CISCOSKILLS) Topology Table for AS(1)/ID(10.3.1.1)
45Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
46      r - reply Status, s - sia Status 
47
48P 10.0.1.0/30, 1 successors, FD is 1310720, serno 1
49       via Connected, GigabitEthernet0/1
50P 10.0.1.4/30, 1 successors, FD is 1310720, serno 2
51       via Connected, GigabitEthernet0/2
52P 10.0.1.8/30, 2 successors, FD is 1966080, serno 17
53       via 10.0.1.2 (1966080/1310720), GigabitEthernet0/1
54       via 10.0.1.6 (1966080/1310720), GigabitEthernet0/2
55P 10.2.1.0/24, 1 successors, FD is 1966080, serno 8
56       via 10.0.1.6 (1966080/1310720), GigabitEthernet0/2
57       via 10.0.1.2 (2621440/1966080), GigabitEthernet0/1
58P 10.1.1.0/24, 1 successors, FD is 1966080, serno 18
59       via 10.0.1.2 (1966080/1310720), GigabitEthernet0/1
60       via 10.0.1.6 (2621440/1966080), GigabitEthernet0/2
61P 10.3.1.0/24, 1 successors, FD is 1310720, serno 3
62       via Connected, GigabitEthernet0/3

That's all I got for now for a basic configuration of EIGRP name mode and I hope this helpful. If you are using Cisco VIRL you can find the project I was referencing using this link Github. There is a subtype that is added in this configuration which was the Windows XP image I was working with. You can find more information about import Windows VMs and other 3rd Party systems into VIRL by checking out a previous post: Cisco VIRL and Windows VMs

What about if you are already running the classic mode of EIGRP and want to migrate over to EIGRP name mode? First check your IOS release and if its 15.4 or higher you likely have a command available that will do the migration for you, instead of removing the classic configuration manaully. Go into your existing EIGRP configuration and type eigrp upgrade-cli followed by the name you want. Voila!

1R3(config)#router eigrp 30
2R3(config-router)#eigrp upgrade-cli ?
3  WORD  EIGRP Virtual-Instance Name

Comments:

GLBP Load Balancing – Cisco Skills -

[…] with three routers in each LAN. I also have a routing protocol running  between the routers (Named EIGRP) to better handle the multiple paths as well as recover from failed […]